#

Git – Apple license requirement message

Mac OSX uses Apple's Xcode for its git integration. However, if Xcode's license has changed you will have to accept it before you can proceed.

The error you will see is similar to:
"Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo."

To accept the license without opening the Xcode GUI, you can use the following command:

sudo xcodebuild -license

You can then re-try your git command.

CC BY-NC 4.0 This work is licensed under a Creative Commons Attribution-NonCommercial 4.0 International License. Permissions beyond the scope of this license may be available at Attribution.